at-spi2-core 1:2.38.0-1 (znver1;i686;x86_64) 2020-12447
9999

Submitter nobodydead [@T] gmail.com
Platform rolling
Repository main
URL https://abf.openmandriva.org/build_lists/825282
Packages
at-spi2-core-1:2.38.0-1.znver1.source
at-spi2-core-1:2.38.0-1.znver1.binary
at-spi2-core-debuginfo-1:2.38.0-1.znver1.debuginfo
at-spi2-core-debugsource-1:2.38.0-1.znver1.binary
lib64atspi0-1:2.38.0-1.znver1.binary
lib64atspi0-debuginfo-1:2.38.0-1.znver1.debuginfo
lib64atspi-devel-1:2.38.0-1.znver1.binary
lib64atspi-gir2.0-1:2.38.0-1.znver1.binary
libatspi0-1:2.38.0-1.znver1.binary
libatspi0-debuginfo-1:2.38.0-1.znver1.debuginfo
libatspi-devel-1:2.38.0-1.znver1.binary
at-spi2-core-1:2.38.0-1.i686.source
at-spi2-core-1:2.38.0-1.i686.binary
at-spi2-core-debuginfo-1:2.38.0-1.i686.debuginfo
at-spi2-core-debugsource-1:2.38.0-1.i686.binary
libatspi0-1:2.38.0-1.i686.binary
libatspi0-debuginfo-1:2.38.0-1.i686.debuginfo
libatspi-devel-1:2.38.0-1.i686.binary
libatspi-gir2.0-1:2.38.0-1.i686.binary
at-spi2-core-1:2.38.0-1.x86_64.source
at-spi2-core-1:2.38.0-1.x86_64.binary
at-spi2-core-debuginfo-1:2.38.0-1.x86_64.debuginfo
at-spi2-core-debugsource-1:2.38.0-1.x86_64.binary
lib64atspi0-1:2.38.0-1.x86_64.binary
lib64atspi0-debuginfo-1:2.38.0-1.x86_64.debuginfo
lib64atspi-devel-1:2.38.0-1.x86_64.binary
lib64atspi-gir2.0-1:2.38.0-1.x86_64.binary
libatspi0-1:2.38.0-1.x86_64.binary
libatspi0-debuginfo-1:2.38.0-1.x86_64.debuginfo
libatspi-devel-1:2.38.0-1.x86_64.binary
Build Date 2020-09-14 19:42:44 +0000 UTC
Last Updated 2020-09-19 03:26:52.336890983 +0000 UTC
$ git diff --patch-with-stat --summary 60c6e226543460cb3401f403b6e57e7b643b1b74..bf14e3a2aba1018c956689eb02671d5b055f5727

 .abf.yml          |  2 +-
 at-spi2-core.spec | 67 ++++++++++++++++++++++++++++++++++++++++++++++++++++++-
 2 files changed, 67 insertions(+), 2 deletions(-)

diff --git a/.abf.yml b/.abf.yml
index eb082fc..138f78a 100644
--- a/.abf.yml
+++ b/.abf.yml
@@ -1,2 +1,2 @@
 sources:
-  at-spi2-core-2.34.0.tar.xz: 6212500401e8e33fd9646bbd666da975dbb19d2f
+  at-spi2-core-2.38.0.tar.xz: c03c5767e19baa42016b496329675125d183e266
diff --git a/at-spi2-core.spec b/at-spi2-core.spec
index 02a83db..d87a005 100644
--- a/at-spi2-core.spec
+++ b/at-spi2-core.spec
@@ -1,3 +1,9 @@
+# at-spi2-core is used by at-spi2-atk, at-spi2-atk is used by gtk-3.0,
+# gtk-3.0 is used by wine
+%ifarch %{x86_64}
+%bcond_without compat32
+%endif
+
 %define url_ver	%(echo %{version}|cut -d. -f1,2)
 
 %define major	0
@@ -5,12 +11,14 @@
 %define libname	%mklibname atspi %{major}
 %define girname	%mklibname atspi-gir %{api}
 %define devname	%mklibname -d atspi
+%define lib32name	%mklib32name atspi %{major}
+%define dev32name	%mklib32name -d atspi
 %bcond_with	bootstrap
 %bcond_with	gtkdoc
 
 Summary:	Protocol definitions and daemon for D-Bus at-spi
 Name:		at-spi2-core
-Version:	2.34.0
+Version:	2.38.0
 Release:	1
 Epoch:		1
 Group:		System/Libraries
@@ -38,6 +46,22 @@ BuildRequires:	gtk-doc
 %endif
 Requires:	dbus
 
+%if %{with compat32}
+BuildRequires:	devel(libdbus-1)
+BuildRequires:	devel(libgio-2.0)
+BuildRequires:	devel(libglib-2.0)
+BuildRequires:	devel(libgobject-2.0)
+BuildRequires:	devel(libz)
+BuildRequires:	devel(libbz2)
+BuildRequires:	devel(libmount)
+BuildRequires:	devel(libblkid)
+BuildRequires:	devel(libX11)
+BuildRequires:	devel(libXi)
+BuildRequires:	devel(libXtst)
+BuildRequires:	devel(libsystemd)
+BuildRequires:	devel(libxkbcommon)
+%endif
+
 %description
 at-spi allows assistive technologies to access GTK-based
 applications. Essentially it exposes the internals of applications for
@@ -78,8 +102,34 @@ Provides:	%{name}-devel = %{version}-%{release}
 This package provides the necessary development libraries and include 
 files to allow you to develop with %{name}.
 
+%if %{with compat32}
+%package -n %{lib32name}
+Summary:	Libraries for %{name} (32-bit)
+Group:		System/Libraries
+
+%description -n %{lib32name}
+This package contains libraries used by %{name}.
+
+%package -n %{dev32name}
+Summary:	Libraries and include files with %{name} (32-bit)
+Group:		Development/GNOME and GTK+
+Requires:	%{devname} = %{EVRD}
+Requires:	%{lib32name} = %{EVRD}
+
+%description -n %{dev32name}
+This package provides the necessary development libraries and include 
+files to allow you to develop with %{name}.
+%endif
+
 %prep
 %autosetup -p1
+%if %{with compat32}
+%meson32 \
+	-Denable-introspection=no \
+	-Denable_docs=false \
+	-Dsystemd_user_dir=%{_prefix}/lib/systemd/user
+%endif
+
 %meson \
 %if %{with bootstrap}	
 	-Denable-introspection=no \
@@ -90,9 +140,15 @@ files to allow you to develop with %{name}.
 	-Dsystemd_user_dir=%{_prefix}/lib/systemd/user
 
 %build
+%if %{with compat32}
+%ninja_build -C build32
+%endif
 %ninja -C build
 
 %install
+%if %{with compat32}
+%ninja_install -C build32
+%endif
 DESTDIR="%{buildroot}" %ninja install -C build
 
 %find_lang %{name}
@@ -125,3 +181,12 @@ DESTDIR="%{buildroot}" %ninja install -C build
 %if !%{with bootstrap}
 %{_datadir}/gir-1.0/Atspi-%{api}.gir
 %endif
+
+%if %{with compat32}
+%files -n %{lib32name}
+%{_prefix}/lib/libatspi.so.%{major}*
+
+%files -n %{dev32name}
+%{_prefix}/lib/*.so
+%{_prefix}/lib/pkgconfig/*.pc
+%endif
Not Available
benbullard79 [@T] cox.netPerfect packages, no one ever says a word!6d 20hrs
benbullard79 [@T] cox.netFantastic!6d 20hrs