dracut 053-4 (znver1) 2021-13802
9999

Submitter tpgxyz [@T] gmail.com
Platform 4.2
Repository main
URL https://abf.openmandriva.org/build_lists/34826
Packages
dracut-053-4.znver1.binary
dracut-053-4.znver1.source
dracut-debuginfo-053-4.znver1.debuginfo
dracut-debugsource-053-4.znver1.binary
Build Date 2021-03-30 07:20:46 +0000 UTC
Last Updated 2021-04-07 18:22:01.813167077 +0000 UTC
$ git diff --patch-with-stat --summary 8987838c3a0ec537d7408f6a7b9a50cd3772db27..6219695b3bd827b7726e16e3d8fa614713a2ed8d

 dracut.spec | 48 ++++++++++++++++++++++++++----------------------
 1 file changed, 26 insertions(+), 22 deletions(-)

diff --git a/dracut.spec b/dracut.spec
index 0be33b4..d103d70 100644
--- a/dracut.spec
+++ b/dracut.spec
@@ -6,7 +6,7 @@
 Summary:	Next generation initrd image generator
 Name:		dracut
 Version:	053
-Release:	2
+Release:	4
 Group:		System/Base
 License:	GPLv2+
 URL:		https://dracut.wiki.kernel.org/
@@ -37,39 +37,38 @@ Patch1018:	dracut-044-bsdcpio-compat.patch
 BuildRequires:	docbook-dtd45-xml
 BuildRequires:	docbook-style-xsl
 BuildRequires:	xsltproc
-BuildRequires:	dash
 BuildRequires:	bash
 BuildRequires:	asciidoc
 BuildRequires:	systemd-macros
 BuildRequires:	bash-completion
 BuildRequires:	pkgconfig(libkmod)
-Suggests:	plymouth
-Requires:	udev
-Requires:	util-linux
-Requires:	kmod >= 27-3
-Requires:	e2fsprogs
-Requires:	f2fs-tools
+Requires:	bash
+Requires:	coreutils
 Requires:	cpio
+Requires:	filesystem
 Requires:	findutils
 Requires:	grep
-Requires:	coreutils
-Requires:	bash
-Requires:	kbd
-Requires:	tar
+Requires:	kmod >= 27-3
+Requires:	sed
+%ifarch %{armx}
+Requires:	gzip
+%else
+Recommends:	xz
 Recommends:	gzip
 Recommends:	bzip2
-Requires:	file
-Requires:	bridge-utils
+Recommends:	gzip
 Requires:	zstd
-Requires:	dmraid
-Recommends:	xz
-Requires(post):	systemd >= 228
-Requires(post):	filesystem
-Requires(post):	coreutils
-Requires(post):	rpm-helper
+%endif
+Requires:	util-linux
+Requires:	systemd >= 228
+Requires:	procps-ng
+Requires:	kbd
+Requires:	file
 %ifarch %{ix86} %{x86_64}
-Requires(post):	kernel
+Requires:	kernel
+Suggests:	plymouth
 %endif
+
 Conflicts:	mkinitrd < 6.0.93-10
 Conflicts:	nash < 6.0.93-10
 Obsoletes:	dracut < 013
@@ -116,14 +115,19 @@ install -c -m 755 %{SOURCE17} modules.d/01xorgblacklist/xorgblacklist.sh
 %make_install
 
 install -m 644 %{SOURCE3} %{buildroot}%{_prefix}/lib/dracut/dracut.conf.d
+
 %ifnarch %{ix86} %{x86_64}
 # Microcode loading is x86 specific
 sed -i -e 's,^early_microcode,# early_microcode,' %{buildroot}%{_prefix}/lib/dracut/dracut.conf.d/50-dracut-distro.conf
 %endif
+
 %ifarch %{aarch64}
 # aarch64 bootloaders generally don't support zstd compressed initramfs
-sed -i -e 's,zstd,gzip,g' %{buildroot}%{_prefix}/lib/dracut/dracut.conf.d/50-dracut-distro.conf
+sed -i -e 's,^compress=.*$,compress="gzip",' %{buildroot}%{_prefix}/lib/dracut/dracut.conf.d/50-dracut-distro.conf
+# do not add weird drivers for this arch
+sed -i -e '/^add_drivers/d' %{buildroot}%{_prefix}/lib/dracut/dracut.conf.d/50-dracut-distro.conf
 %endif
+
 mkdir -p %{buildroot}%{_sysconfdir}/dracut.conf.d
 
 echo "DRACUT_VERSION=%{version}-%{release}" > %{buildroot}%{_prefix}/lib/dracut/dracut-version.sh
Not Available
benbullard79 [@T] cox.netNo Comment.40d 00hrs
benbullard79 [@T] cox.netNo Comment.40d 00hrs